EC2onRailsの0.9.8.1を使って、0.9.7時代のAMIイメージに cap deployしようとした場合、なぜか/etc/init.d/以下のいくつかの 起動スクリプトの実行パーミッションが剥奪されてしまい、 デプロイ処理の途中でエラーが起きて中断してしまうようです。

とりあえず対処療法として、Capfileの中で

   1  load 'deploy' if respond_to?(:namespace) # cap2 differentiator
   2  load 'config/deploy'
   3  gem 'ec2onrails', '=0.9.7'
   4  require 'ec2onrails/recipes' 

のように0.9.7を明示的に指定するようにして回避しています。 本家筋のAMIイメージへの変更をマージしていく必要がありそうですね。

posted by Png genki on Tue 27 May 2008 at 11:38
Contents
EC2onRails-0.9.8.1を古いAMIイメージで使う場合の注意点
Comments
dsjf: https://gist.github.com/6bf1bf2c3cbb5eb6e7a7 これ... '13-1
瀧内元気: おお、チェックしてみます。thx! '11-12
overisland: Reeder for iPhone もこの UI を実装していますね。 '11-12
瀧内元気: その情報は見たのですが、以下のサイトによると、現在はまた必要になってるっぽいんですよね。 ... '11-12
tkawa: http://devcenter.heroku.com/articles/rails31_he... '11-12
Services from s21g
twpro(ツイプロ)
Twitterプロフィールを快適検索
地価2009
土地の値段を調べてみよう
MyRestaurant
自分だけのレストラン手帳
Formula
ブログに数式を埋め込める数式コミュニティ