RubyGemsを使い続けていると、古いバージョンのgemがたまっていきますが、 まとめて綺麗にする方法のメモ。

   1  # gem uninstall activesupport -v '<= 2.0.1'
   2  
   3  Select gem to uninstall:
   4   1. activesupport-1.4.2.6548
   5   2. activesupport-1.4.2.7357
   6   3. activesupport-1.4.4
   7   4. activesupport-2.0.1
   8   5. All versions
   9  > 5

このように、-vオプションで不等号によるバージョンの指定 を行い、All versionsを削除すると、まとめて 一度に削除できます。

posted by Png genki on Tue 25 Dec 2007 at 16:03
Contents
複数のRubyGemsをまとめてuninstallする方法
Comments
dsjf: https://gist.github.com/6bf1bf2c3cbb5eb6e7a7 これ... '13-1
瀧内元気: おお、チェックしてみます。thx! '11-12
overisland: Reeder for iPhone もこの UI を実装していますね。 '11-12
瀧内元気: その情報は見たのですが、以下のサイトによると、現在はまた必要になってるっぽいんですよね。 ... '11-12
tkawa: http://devcenter.heroku.com/articles/rails31_he... '11-12
Services from s21g
twpro(ツイプロ)
Twitterプロフィールを快適検索
地価2009
土地の値段を調べてみよう
MyRestaurant
自分だけのレストラン手帳
Formula
ブログに数式を埋め込める数式コミュニティ